Измерения

Измеритель C и ESR

1 | Стр. 46 | 157

Здравствуйте уважаемые коллеги. Если есть интерес посмотрите это чудо - буржуйский ESR-метер
Это ссылка на него - http://www.elektor.com/magazines/2005/september/esr-c-tester.57856.lynkx

 

Собрал прибор (PIC16F876A прошивка go_esr_1_01.HEX) проверил напряжения (-4,87и 5,01), подогнал ток к 10ма,поставил все в панели и включил при включении на индикаторе : Сх _ _ _,
ESR 0.000. Начал с подключения емкости подогнал коэфициент Сx к значению 0.760 и получил реальные показания измеряемых конденсаторов по емкости, но вот с ESR и измерением сопротивления возникли сложности,сопротивление мерять отказывается и при попытке выставить U0 при нажатом плюсе и закороченном входе на индикаторе имеем разницу в показаниях 1 ОМ и 1 0ОМ 0014 и 0001 соответственно, при вращении R4 показания меняются пропорционально и по максимуму доходят до 0879 по 1 ОМ и 0095 по 10 ОМ.
Может кто подскажет где копать я в ходе эксперементов менял VT1, VT2, DA1,DA2,DA3,VD2, и это не как не отражалось на работе прибора

 

ttt55: при попытке выставить U0 при нажатом плюсе и закороченном входе на индикаторе имеем разницу в показаниях 1 ОМ и 1 0ОМ 0014 и 0001 соответственно
Непонятно, в чем проблема. Эти показания при закороченном входе по двум каналам и не должны совпадать. Пусть будут 0014 и 0001, нажимайте кнопку Set - эти числа запишутся как U0 и потом будут вычитаться при измерениях.

 

Эти показания при закороченном входе по двум каналам и не должны совпадать. Пусть будут 0014 и 0001, нажимайте кнопку Set - эти числа запишутся как U0 и потом будут вычитаться при измерениях.
Так и делал U0 сохраняется а при подключении резисторов от 1 до 10 Ом пишет ESR 0.000 а емкостя меряет на ура.Тут у меня еще подозрение возникло а не может ли PIC мозг парить?

 

ttt55: при подключении резисторов от 1 до 10 Ом пишет ESR 0.000
Если корректирующие к-ты для каналов 1 и 10 Ом случайно не равны нулю (проверьте), то проблему следует искать в монтаже/деталях в районе DD2.

 

проблему следует искать в монтаже/деталях в районе DD2
попробую сдуть все smd на DD2 перемерять и перезвонить дороги,может где промазал или лоханулся.

 

проблему следует искать в монтаже/деталях в районе DD2
Поменял CD4066 на другого производителя и все поехало
GO спасибо за внимание и поддержку.

 

Собрал, заработал сразу. Откалибровал. Работает.
При подключении керамического или пленочного конденсатора 0,1 мкф показывает ESR ноль ом, при подключении паралельно ему электролитического конденсатора показывает ESR электролитического конденсатора. Это у всех так?
И еще, при измерении ёмкости больше 1000 мкф не мешало-бы убрать запетую.

 

В схеме 3 одинаковых электролита 220 мкф. Ёмкость одного показывает правильно, двух завышает до 740 мкф, при выпаивании всё нормально.
Ничего особенного. Конечно, если у кого-то до сих пор ничего небыло ................

 

Culibin: при подключении паралельно ему электролитического конденсатора показывает ESR электролитического конденсатора.
Так и должно быть, это особенности способа измерения в данном приборе, т.к. измерения фактически производятся на постоянном токе. Когда параллельно электролитическому включен пленочный после достижения заданного напряжения отключается зарядный ток и напряжения на конденсаторах быстро уравниваются. Если ёмкость плёночного много меньше ёмкости электролитического, то и его влияние на измеренную разницу напряжений окажется незначительным. Следовательно и измеренное значение ESR практически не будет зависеть от наличия плёночного конденсатора.

 
1 46 157