RSS  |  PDA

Это реклама. Ссылки открываются в новом окне.
Измерения

Измеритель RLC-2

1 | Стр. 346 | 691
Voda
23.04.2011, 21:29

Нет, победил, я всё таки этот индикатор.
Вот вложение, может кому пригодиться, кусок схемы не от RLC-2 но смысл понятен: нельзя тревожить rs пока идёт запись в индикатор.

# 
Voda
23.04.2011, 21:33

Что то не прилепляется ничего
http://s016.radikal.ru/i335/1104/6d/0b25944e6e24.jpg

# 
GO
24.04.2011, 15:36

Voda: Нет, победил, я всё таки этот индикатор.
Все-таки добили, поздравляю!
А кроме RS, изменения в коде потребовались?

# 
Voda
24.04.2011, 15:54

GO: А кроме RS, изменения в коде потребовались?
Нет, не потребовались, как только мне предложили данную схемку, сразу залил оригинальную прошивку и всё пошло,
также убрал RC цепочку, без неё тоже работает.

# 
Voda
24.04.2011, 16:07

Прибор мой уже, кстати в корпусе, и меряет вовсю, быстро я его состряпал
Запустимши его, я был поражён точностью и неприхотливостью к настройке.Огромное спасибо авторам, отличная разработка!

# 
kot66
25.04.2011, 18:55

Собрал прибор по исправленной схеме на СМД деталях (схема и пп от KIV), АЦП TI, МАХ7400, делитель собран на 74HC393D и 74HC74D. Установил как советовали на форуме необходимые напряжения, провёл калибровку - прибор получился отменный. Пользуюсь уже неделю.
Однако время от времени при подсоединении радиодеталей прибор виснет, т.е. начинает мигать поочерёдно А0, А1 на индикаторе, при этом пропадает сигнал на выходах триггера 4HC74D (0_Clk, 90_Clk), хотя на входе сигнал не исчезает, для выхода из этого состояния, прибор необходимо выключить и включить снова. Самое обидное, что проследить взаимосвязь зависания с определёнными действиями не получается. Прошивка была 1.2 теперь 1.3, думал, что пройдёт, но зависание не ушло, правда стало реже проявляться.
Может кто подскажет, что бы это могло быть и как с этим бороться.
За ранее благодарен.

# 
Арс ◊
25.04.2011, 19:52

У меня, кстати, тоже иногда такое проявляется. Особенно когда индуктивности меряю. В основном замечано на частоте 1кГц. И тоже колебание между А0, А1, такое ощущение, что прибор не может автоматом выбрать предел, на одном перегрузка по току, а на другом перегрузка по напряжению. Но это только предположение. Выхожу из положения переключая частоту измерения на 100 или 10 000Гц.

# 
Voda
25.04.2011, 21:16

kot66: Может кто подскажет, что бы это могло быть и как с этим бороться.
Было.
Проверьте щупы не контачит ли где нибудь центральная жила на оплётку, почистите контактные площадки, ну и с деталью хороший контакт должен быть.

# 
kot66
25.04.2011, 21:18

Спасибо за совет Арс, завтра, если возникнет необходимость, попробую переключить частоту измерения.

# 
kot66
25.04.2011, 21:33

Щупы вроде нормальные, центральные жилы с оплётками не звонятся, контактные площадки выполнены из серебряной фольги. Меня больше волнует, что при таких миганиях А0 и А1 пропадает сигнал на входе МАХ7400 и соответственно и измерительный синусоидальный сигнал.

# 
Страницы:
336  337  338  339  340  341  342  343  344  345  346  347  348  349  350  351  352  353  354  355  356 

Загруженные файлы