RSS  |  PDA

Это реклама. Ссылки открываются в новом окне.
Измерения

Измеритель C и ESR

1 | Стр. 99 | 157
miron63
07.01.2011, 22:12

Это программная ошибка.
такое возможно только в одном случае если EEPROM записано FF.
Прочитай и сравни. Нормально запиши и всё заработает.

# 
kiv69
08.01.2011, 01:11

miron63: Это программная ошибка.
такое возможно только в одном случае если EEPROM записано FF.
Прочитай и сравни. Нормально запиши и всё заработает.

Кажется, проблема найдена
Загружаю в micropro go_esr_1_0.HEX.
EEPROM DATA
0000 00 00 03 E8 00 00 03 E8
0008 81 60 00 00 78 74 89 8D
0010 80 40 00 00 FF FF FF FF
Далее всё FF

Загружаю в IC-Prog go_esr_1_0.HEX.
EEPROM DATA
0000 00 00 03 E8 00 00 03 E8
0008 00 00 03 E8 85 16 00 00
0010: 81 60 00 00 75 40 30 0C
0018: 78 74 89 8D 74 2E C3 3E
0020: 80 40 00 00 FF FF FF FF
Далее всё FF

Похоже, micropro некорректно открывает go_esr_1_0.HEX.
Сейчас забью данные EEPROM вручную и попробую.

# 
kiv69
08.01.2011, 01:42

kiv69: Сейчас забью данные EEPROM вручную и попробую.
Всё заработало.
miron63, большое спасибо за помощь.

# 
Serge3
10.01.2011, 11:44

У меня тоже пик прошился нормально только со второго раза.

# 
ksvserega
14.01.2011, 15:43

Заранее прошу прощения, но тему в 99 страниц всю целиком не осилил. Интересует только измеритель С и ESR. Схема с прошивкой в архиве из первой странички рабочая? Это окончательный вариант со всеми пожеланиями/замечаниями или нужно шерстить все страницы подряд? И, случайно, никто не делал сей девайс в не-SMD исполнении? платкой не поделитесь.

# 
AlexM
14.01.2011, 16:34

ksvserega: И, случайно, никто не делал сей девайс в не-SMD исполнении? платкой не поделитесь.

Здесь: http://monitor.net.ru/forum/topic275311-224.html Выкладывали.


# 
ksvserega
14.01.2011, 17:29

AlexM, в приведенной картинке и ссылке просто переработана ПП, а ВСЕ компоненты SMD, нет ни одного DIP и т.п.

# 
jim
24.01.2011, 14:28

здравствуйте! собрал прибор.такой вопрос. при включении показывает следующее:
Сх ---
ESR >0.000 Ом.
сопротивление что у конденсатора что у резисторов мерит нормально.хотя не очень. резитор 10 ом не определяет. резистор в 0.2 ома нормально. сопротивление конденсатора тоже определяет.
при нажатой кнопкой + подстроечником выставил мин значение на показании 1 ом = 0003 (щупы замкнуты)
коефициенты не менял. все по 1,000.
емкость не показывает.
сопротивление 10 ом тоже.

где искать ошибку?

# 
Serge3
24.01.2011, 23:12

Проверь питание на LM393,у меня такое было,когда не запаял перемычку с +5В. А кто подскажет тип реле в приставке LCF(а то не охота гнуть ножки)?

# 
jim
25.01.2011, 00:34

на 8 ножке 393-й есть наличие +5В.
на схеме минусовое напряжение -4,58В

# 
Страницы:
89  90  91  92  93  94  95  96  97  98  99  100  101  102  103  104  105  106  107  108  109 

Загруженные файлы